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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

1. Modelos de carga de tráfico para Turquía

▪ Se implementaron cinco modelos turcos de carga viva en midas Civil. KGM-45, H30-S24, H30-S24L, H20-S16, H20-S16L

▪ Estos vehículos se pueden encontrar a partir del código estándar AASHTO LRFD / AASHTO.

▪ Load/Moving Load Analysis Data > Vehicles

Carga Vehicular Estándar KGM-45 Trazador de Carga Móvil, KGM-45
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

1. Modelos de carga de tráfico para Turquía

▪ Load/Moving Load Analysis Data > Vehicles

Carga Vehicular Estándar, H30-S24

Carga Vehicular Estándar , H30-S24L Carga Vehicular Estándar, H20-S16L

Carga Vehicular Estándar, H20-S16
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

2. Optimización de Carga Móvil para Australia

▪ Ahora, la función de optimización de la carga móvil se puede aplicar también con el

código de Australia.

▪ La optimización de carga móvil amplía las capacidades del análisis de carga móvil y

ayuda a simplificar significativamente la evaluación de ubicaciones críticas de vehículos.

Las ubicaciones críticas de los vehículos se pueden identificar en la dirección transversal

así como en la dirección longitudinal de acuerdo con la disposición del código.

▪ Load > Moving Load > Traffic Line/Surface Lane > Moving Load Optimization

▪ Load > Moving Load > Moving Load Cases

Optimización de Línea de Tráfico Caso de Carga MóvilResultados Optimizados para Vigas Exteriores por S1600
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

3. Normas para puentes IRS India: cargas ferroviarias

▪ Todas las cargas ferroviarias aplicables ahora podrían aplicarse directamente a cualquier estructura. La carga de tracción y de frenado de la locomotora y del vagón se

consideraría automáticamente.

▪ Loads> Moving Load> India> Vehicles> IRS Bridge Rules

▪ Analysis> Moving Load Analysis Control > Railway Bridge Information
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

4. Links Elásticos No Lineales para Análisis Pushover

▪ El comportamiento no lineal de los links elásticos, es decir, solo-comp., solo-tens., multi-linear se puede tener en cuenta en el análisis de pushover.

▪ Las fuerzas de links importadas desde el análisis estático o el análisis de etapas constructivas no se pueden especificar como cargas iniciales para el análisis de

pushover.

▪ Pushover > Control > Global Control

Bi-linear

Elastic Links

representing 

soil resistance

Control Global de Pushover
Análisis Pushover para Pilas y Pilotes
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

5. GSD - Cálculo del ancho de fisuración según IRC 112: 2011

▪ Para cualquier sección irregular, el ancho de fisura elástico y fisurado-elástico pueden ser calculados según el código IRC 112: 2011.

▪ Se puede obtener un informe Excel del cálculo del esfuerzo y el ancho de la fisura

▪ GSD > Design Section > Crack width > Report
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

6. Actualización AASHTO LRFD 2016

▪ Combinación de Carga

▪ Los factores de carga de WS para Resistencia III, Resistencia V, Servicio I, Servicio IV se cambiaron de 1.4 a 1.0, 0.4 a 1.0, 0.3 a 1.0, 0.7 a 1.0, respectivamente.

▪ El factor de carga de los efectos permanentes para el Evento Extremo I se cambió de γp a 1.0. AASHTO-LRFD 2012 usaba un valor para γp mayor que 1.0.

Cuadro de Combinaciones de Carga
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

6. Actualización AASHTO LRFD 2016

▪ Factor de Resistencia

▪ εcl : límite de deformación controlada por compresión en el extremo de acero a tensión

▪ εtl : límite de deformación controlada por tensión en el extremo de acero a tensión

AASHTO 2012 AASHTO 2016
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

7. Diseño de elementos tipo Shell

▪ Se implementó el diseño de los elementos tipo Shell de hormigón reforzado según el Anexo LL de EN 1992-2.

▪ El diseño de elementos tipo Shell considera tres fuerzas de membrana, dos momentos de flexión, momento de torsión y dos fuerzas de cortante transversal.

▪ Esta función de diseño se puede aplicar a la estructura tipo Shell de hormigón reforzado, muros de estribos / muros de ala, estructuras subterráneas.

Fuerzas Axiales en Membrana Fuerzas Cortantes en Membrana

Area de Refuerzo RequeridaEsfuerzos a Compresión Principales



12

Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

7. Diseño de elementos tipo Shell

Step 1. Definición de miembro shell Step 2. Definición de Datos de Refuerzo y Espesor de capa Step 3. Ejecución del diseño y

verificación de los Shells

Diseño de Shell
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

Diseño/Verificación a Flexión de Shell

Los siguientes resultados se pueden mostrar.

1. Fuerza Axial en Membrana
2. Fuerza Cortante en Membrana
3. Esfuerzo de barras
4. As_req

(área de refuerzo requerida)
5. Rho_req

(índice de refuerzo requerido)
6. Configuración de barras de refuerzo

Resultados de Barras de Refuerzo

Tabla de Resultados

Resultados de Concreto

Los siguientes resultados se pueden mostrar.

1. Fuerza Axial en Membrana
2. Fuerza Cortante en Membrana
3. Esfuerzo Principal a Compression de Concreto

7. Diseño de elementos tipo Shell
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

Verificación de Cortante en Shell

Los siguientes resultados se pueden mostrar.

1. V_Edo
2. Resistencia a Cortante del Concreto
3. Índice de Resistencia

Resultado de Cortante

Tabla de Resultados

7. Diseño de elementos tipo Shell
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

Concepto de Diseño de Shell

Transverse shear forces

Plate components

Slab components

Capas externas resisten los
momentos flectores + 
fuerzas en membranas

Capa interna resiste el 
cortante transversalear

• Shell o elemento de placa sometido a fuerzas de membrana Nx, Ny, Nxy + fuerzas de flexión Mx, My, Mxy

• Resistido por las fuerzas de tensión resultantes del refuerzo + fuerzas de compresión resultantes del hormigón

7. Diseño de elementos tipo Shell
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

Procedimiento para Diseño de Shell

Max. Esfuerzo de Compresión < Resistencia→ O.K.
No fisurada

Revisión de Fuerzas de Plates en el análisis

Revisión de Fisura

Definición del modelo Sandwich

Fisurada

Cálculo de Fuerza de Membrana

Caálculo de esfuerzos de refuerzo y concreto

Definición de Configuración de Barras de Refuerzo

Cálculo de Resistencia de refuerzo y concreto

Esfuerzo < Resistencia → O.K.

: Obtenido de la columna ‘Plate force(UL:UCS)’ de la tabla Plate Stress

7. Diseño de elementos tipo Shell
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

Procedimiento para Diseño de Shell

Revisión de Fisura

→ No Fisurada,     If Φ>0.0, Cracked

σ1 = Max. [σx, σy] = Max. [Fxx, Fyy]

σ2 = Min. [σx, σy] = Min. [Fxx, Fyy]

σ3 = 0

σ3

Tabla Plate Stress (UL : UCS)

7. Diseño de elementos tipo Shell
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

Procedure of Shell Design

Definición de Modelo Sandwich

• Usa ‘ 0.2*h’ como valor por defecto. 

• Si se selecciona “ Consider Iteration for optimal design”, 
el espesor de la capa se calcula automáticamente. 

Espesor Sandwich

Cálculo de Fuerza en Membrana

• La geometría del elemento sandwich debe ser conocida para calcular las fuerzas de la membrana (Nxk, Nyk, Nxyk).

7. Diseño de elementos tipo Shell
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

Procedimiento para el Diseño de Shell

Cálculo de Espesor de Sandwich para Diseño óptimo - 1

k=Capa de Compresión

j = Capa de Tensión

ck0 : 1ra estimación de ck

ck : la profundidad de bloque de compresión

Revisión de Momento Principal

Definición de Comp. / Tens. Por signo de momento

Cal. de Momento Resultante, Ma

Cal ck0 por Ecuaciones
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7. Diseño de elementos tipo Shell
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

Procedimiento para Diseño de Shell

k= Capa en Compresión

j = Capa en Tensión

Fuerza de Membrana en Capa de Compresión.
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Cálculo de Espesor de Sandwich para Diseño óptimo - 2

Cuando

Cuando se excluye

Fuerza de Compresión de Concreto.

7. Diseño de elementos tipo Shell
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

Procedimiento para Diseño de Shell

Cálculo de Fuerza de Membrana en capa de Tensión y área de barrras requerida

Cálculo de fuerzas de membrana en capa de tensión.

Cálculo de fuerzas de compresión en refuerzo en capa de compresión.

En Gen, Ignora fuerzas de Comp. en refuerzo (área de barras requerida por comp. es 0)

Cálculo de fuerzas de tensión en refuerzo en capa de tensión.

Areq,x = Nxaj / fyd

Areq,y = Nyaj / fyd

Cálculo de área de barras requerida en capa de tensión.

7. Diseño de elementos tipo Shell
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

Procedimiento para Diseño de Shell

Cálculo de fuerza de refuerzo (Capa de Tensión) y concreto (Capa de compresión)
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Nxak, Nyak : fuerzas de tensión en refuerzo colocadas en dirección x y y en capa k

Nck : Fuerza de compression de concreto en capa k

7. Diseño de elementos tipo Shell
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Análisis & Diseño

Procedimiento para Diseño de Shell

Modificación de Fuerza de Tensión considerando la ubicación de las barras de refuerzo

Distancia desde el centro de la sección hasta el centro de la barra exteriora

Distancia desde el centro de la sección hasta el el centro del espesor de sandwich

7. Diseño de elementos tipo Shell
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Pre & Post-Procesamiento

The shear span value is user input.
If it is less than 0, it is treated as an error. 

= +A S HE E E
SE HE

= +A S HE E E

HE

SE

1. Gráfico de resultados de energía para el análisis tiempo historia 

▪ Imprima el gráfico de resultados de energía para los dispositivos de control de vibración y aislamiento en el análisis tiempo historia no lineal.

▪ Result > T.H. Graph/Text > Time History Energy Graph
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Pre & Post-Procesamiento

1. Gráfico de resultados de energía para el análisis tiempo historia

The shear span value is user input.
If it is less than 0, it is treated as an error. 

▪ Result > T.H. Graph/Text > Time History Energy Graph
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Pre & Post-Procesamiento

1. Gráfico de resultados de energía para el análisis tiempo historia

The shear span value is user input.
If it is less than 0, it is treated as an error. 

▪ Result > T.H. Graph/Text > Time History Energy Graph

< Resultado en texto de cada índice de energía >
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Pre & Post-Procesamiento

1. Gráfico de resultados de energía para el análisis tiempo historia

The shear span value is user input.
If it is less than 0, it is treated as an error. 

▪ Result > T.H. Graph/Text > Time History Energy Graph

StrtGrp 1F StrtGrp 2F StrtGrp 3F

BndrGrp 1 BndrGrp 2 BndrGrp 3

< Resultado de salida para la distribución en grupo para cada ítem >
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Pre & Post-Procesamiento

▪ Se proporcionan resultados de deformación para materiales plásticos, es decir, Tresca, Von Mises, Mohr-Coulomb, Drucker-Prager y Daño de Concreto.

▪ Se proporcionan índices de daños para la compresión y la tensión para el modelo de “Concrete Damage” “Daño en concreto".

▪ Results >  Results > Strains > Plate Strains/ Solid Strains

2. Resultados de deformación para el análisis no lineal de materiales
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Pre & Post-Procesamiento

2. Resultados de deformación para el análisis no lineal de materiales

▪ Results >  Tables > Results Tables > Plate/ Solid > Strain(local)/ Strain(Global)

<Plate Strain (local) menu> <Solid Strain (local) menu>
Tabla de Deformaciones en Plate
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Pre & Post-Procesamiento

3. Función multi-lineal de fuerza-deformación para Point Spring Support y Elastic Link

▪ La curva multi-lineal para Point Spring Support y Elastic Link se puede definir como una función sin limitación en términos de cantidad de datos.

< Versión Anterior > < Civil 2019 (v1.1)  >

Multi-lineal es definida
en 6 puntos en la 
versión anterior.
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Pre & Post-Procesamiento

4. Informe de análisis de la vía férrea con la configuración de unidades estadounidense

▪ El informe de Análisis de Vías Férreas es compatible con el sistema de unidades de EE. UU. Y con el sistema de unidades SI.

▪ Structure > Wizard > Rail Track Analysis Model > Rail Track Analysis Report

Configuración de Unidades en Reporte Reporte de Análisis de Vías Férreas
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Pre & Post-Procesamiento

5. Interfaz de datos con midas GTS NX

▪ Las reacciones de Point Spring Support se pueden exportar a GTS NX.

▪ Los resultados de fuerza-desplazamiento del suelo pueden ser importados desde GTS NX a midas Civil, y los datos de entrada de los point spring supports multi-lineales son actualizados.

▪ File > Export > Nodal Results for GTS
▪ File > Import > Nodal Results for GTS
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Civil 2019 (v1.1) Nota de LanzamientoCivil 2019 Pre & Post-Procesamiento

6. Interfaz Tekla Structure 2018
▪ La interfaz de Tekla Structures es una herramienta proporcionada para agilizar todo el proceso de modelado, análisis y diseño de una estructura mediante transferencia de datos directa con midas Civil.

▪ La transferencia de datos está limitada a elementos estructurales.

▪ a interfaz de Tekla Structure nos permite transferir directamente los datos de un modelo de Tekla a midas Civil y devolverlo al modelo de Tekla. El archivo de texto de midas Civils (* .mct) se usa para la

transferencia en ambas direcciones.

Category Features Tekla <> Gen

MATERIAL

concrete <>

steel <>

pre cast - wood and other types <>

Material user defined <>

ELEMENT TYPE/

ROTATIONS

vertical column <>

inclined column <>

straight beam <>

curved beam >

Slab <>

vertical panel >

2D ELEMENTS Concrete panels and slab <>

BOUNDARY CONDITIONS

support >

beam end release <>

section offset >

STATIC LOAD

self weigth >

linear load

(uniform or trapezoidal)
<>

MERGE OPTION

new element <>

new element that

divide other elements
<>

topology changes <>

Tekla Structure 2018

Civil 2019

▪ File > Import > midas Civil MCT File
▪ File > Export > midas Civil MCT File


